1. Click here to become an Official Member of BMW Club Malaysia Download Form

F10 Reverse Camera Problem

Discussion in 'F10, F11, F07' started by X5Fan, Oct 9, 2020.

  1. X5Fan

    X5Fan Club Guest

    Joined:
    May 20, 2012
    Messages:
    22
    Likes Received:
    0
    Hi all Sifus,

    Wondering whether anyone has ever had problem with the reverse camera.

    I had a reverse camera retrofitted at Ingress Auto Damansara when I bought an F10 from them in 2015.

    In late August this year, I sent the car to Ingress Auto for a brake fluid change. A software update was also done, after which the reverse camera is not working any more.

    I sent the car back to Ingress Auto in early Sept to get the problem rectified. After 3 weeks of giving me the run-around, the service advisor told me it is likely that the new software update is not compatible with the camera, and they need to refer the problem to their technical department. After another week, I was told that the camera was not compatible with the new software update and they need to check their records on the camera installation.

    Now already 4 weeks and still waiting for the problem to be resolved. Has anyone faced similar problem with the reverse camera after updating the software?

    Any feedback will be much appreciated. Thanks.
     
  2. gendong

    gendong Moderator
    Club Committee

    Joined:
    Feb 7, 2011
    Messages:
    3,410
    Likes Received:
    405
    Thats funny. 1st time hearing of such an issue on a retrofit done by SC. Did they got the installation right in the first place (both the software update and the cam)? But 3 weeks..... like they just clndt care less.....
     
  3. X5Fan

    X5Fan Club Guest

    Joined:
    May 20, 2012
    Messages:
    22
    Likes Received:
    0
    That was exactly my 1st thought. An original BMW reverse camera rendered inoperable after a software update??

    It was working fine for almost 5 years until the so-called software update was done in late August. Already more than 4 weeks Ingress Auto service and technical departments have been tinkering with it. The SA claimed that they are also in contact with BMW Malaysia for advice. They have reinstalled the software over and over again and now seems to conclude it is due to software incompatibility. Of course, they claimed they have never encountered such an issue before.

    Now, they are looking into their records on the installation done 5 years ago and also awaiting their bosses' decision on what to do next !!

    Need to chase after them again this week :mad:
     

Share This Page