1. Click here to become an Official Member of BMW Club Malaysia Download Form

E46 Error Code 211 - LLFS Jammed

Discussion in 'E46' started by jarance, Apr 19, 2013.

  1. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    Nope dont have that charcoal filter as mentioned.. Thanks for the pointer.

    - - - Updated - - -

    Nope dont have that charcoal filter as mentioned.. Thanks for the pointer.
     
  2. eujinee

    eujinee Club Guest

    Joined:
    Sep 20, 2010
    Messages:
    301
    Likes Received:
    1
    so it is solve jarance??? just wan to get myself prepare too ..just in case..my is 370k millage
     
  3. teighlour

    teighlour Club Guest

    Joined:
    Jul 3, 2011
    Messages:
    181
    Likes Received:
    5
    I smell an upgrade coming up. I gave up on my e46 as too many problems and decided one day when I woke up to just get a new car.
     
  4. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    Nope not yet.. The error code triggered after 3 days after changing the crankshaft sensor.

    I have just changed the intake camshaft sensor last weekend and will try it out. have not driven my car last few days.


     
  5. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    Glad to say that there is no error code while driving from Klang to Manjung today.

    Still too early to tell whether the problem is resolved or not.
    Will drive around town for a few more days to confirm.

    - - - Updated - - -

    Glad to say that there is no error code while driving from Klang to Manjung today.

    Still too early to tell whether the problem is resolved or not.
    Will drive around town for a few more days to confirm.
     
  6. eujinee

    eujinee Club Guest

    Joined:
    Sep 20, 2010
    Messages:
    301
    Likes Received:
    1
    lets see......hope it solve your nightmare....
     
  7. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    being driving the car for a week now. So far so good. what I did so far.
    1. change the exhaust cam sensor - no good - new alarm came on (error code 12) so replace it back with the
    old sensor and it was good. New sensor is not good.
    Suspect it is due to the connector as it was difficult to plug it in.

    2. change vanos seal - clear alarm for error code 5e19 - CAN DME engine torgue not adjustable.
    Now running with a bit more torque.(butt dyno)

    3. Clear all adaptation for the DME module using INPA program.

    Note: Need to do this adaptation with the engine NOT running.

    I think most probably item 3 is the most likely solution for error 211.
     
  8. eujinee

    eujinee Club Guest

    Joined:
    Sep 20, 2010
    Messages:
    301
    Likes Received:
    1
    jarance....means u reset ur DME and let it adapt itself again...how it adapt without the engine running???
     
  9. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    I mention CLEAR adaptation, not set the adaptation. The DME will adapt after you drive the car for a few hundred kilometer later.

    Just turn the ignition to second position without starting the car and then clear all adaptation.
     
  10. huskar3399

    huskar3399 Club Guest

    Joined:
    Feb 5, 2012
    Messages:
    844
    Likes Received:
    12
    i did the adaptation when the engine is running. all went fine except for the throttle body adaptation if i am not mistaken. if it is performed while the engine is running the engine will jerk. so the way to do it is when the engine is off.
     
    jarance likes this.
  11. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    I think it is the DSC module...
     
  12. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    Finally, I managed to solve the problem that have been bugging me for some time.

    I wanted to change the DSC module but on the advise of my mechanic, he mention it is OK. (Thanks Mike)

    The reason it is not the DSC module was because the alarm only comes on below the speed of 98KMH.

    before I mention what is the cause, I will drive the car for another week before I conclude that the problem is solved.

    Stay tuned..
     
    UnoS likes this.
  13. Alex5522

    Alex5522 Club Guest

    Joined:
    May 28, 2010
    Messages:
    2,324
    Likes Received:
    21
    That's Birthday gift anywhere happy birthday bro :laugh:
     
    UnoS and jarance like this.
  14. Dexter

    Dexter Club Guest

    Joined:
    Aug 10, 2010
    Messages:
    72
    Likes Received:
    5
    Glad that you finally solved it!
     
    jarance likes this.
  15. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    sorry it does comes back once in a while
     
  16. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    Latest update..

    Finally resolve the issue after changing so many things.

    It was the steering wheel angle sensor. Wanted to change it but try to recalibrate with the INPA program.

    The problem goes away for a few days but it came back again. Check with INPA and found that the calibration was off.
    Recalibrate again and so far the problem have not occurred for 2 months. :rock: :rock:
     
  17. digilife

    digilife Member

    Joined:
    Nov 23, 2015
    Messages:
    65
    Likes Received:
    5
    So far anymore issues ?
     
  18. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    It come and go. Everytime I check the setting, there seem to be some drift even though I have zero it.

    Thinking of changing the steering angle sensor is the next option or try to clean it.
     
  19. digilife

    digilife Member

    Joined:
    Nov 23, 2015
    Messages:
    65
    Likes Received:
    5
    What kind of scanner or diagnostic tool you use to chk your system ?

    Btw will checking some Relay/s solve your issue once & for all ?
     
  20. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    I use BMW Scanner and BMW INPA.

    Nope, there is a diagnostic subroutine in the DME which check the speed of the all the wheels and steering wheel angle and also the lateral acceleration at a pre-determine speed (wheel sensor)

    if all the speed of the wheels are the same and the lateral acceration is zero, then the steering angle should be theorically be ZERO.
    If it not, then it will generate an alarm. DSC, BRAKE and EML. This usually will happen at around 90KPH or less. No alarm when the speed is greater than 110 KPH.

    I have been holding to change the steering angle sensor cos it is a hazzle to do it.
     

Share This Page