1. Click here to become an Official Member of BMW Club Malaysia Download Form

E46 Error Code 211 - LLFS Jammed

Discussion in 'E46' started by jarance, Apr 19, 2013.

  1. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    This problem have been coming on and off for quite sometime with my ride.(Car model is E46/325i/2004/Auto GB/M54 engine.)Whenever the error comes on, the following error lights will be turn on.[​IMG]Scan the error on the DME using INPA and the following error is display: 211 LLFS Error at mechanical. (LLFS Jammed Open)[​IMG]Check the cause of the error and it indicated as follows:-[​IMG]I have changed the following things (all DIY).1. MAF2. CCV3. DISA4. ICV5. Air Intake Hoses[​IMG]Note: 1. My DISA was found to have the vane slightly offset and loose. After changing, the frequency of the alarm is about once a week as compare to about 3 times a week.2. The funny thing is the alarm is always generated at around 1880 rpm and around 90 Km/hr. No alarm is generated when I drive above 100 km/hr or below 60km/hr.3. When the alarm comes on, there is slight lost in power. I can reset the alarm by switching off the engine and restart it. Power is resumed after restart. (I do this while car in motion by shifting gear to neutral)Question:1. What is the root cause of this problem?2. Read somewhere the root cause is due to the Vanos Intake camshaft sensor. (My car never stall) 3. Leak somewhere else?4. Adaptation of the fuel throttle need to carry out?Please help if you have encounter this problem before.
     
  2. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    btw, forgot to mention that both the O2 sensors are also changed.
     
  3. Dexter

    Dexter Club Guest

    Joined:
    Aug 10, 2010
    Messages:
    72
    Likes Received:
    5
    jarance,

    I wish I could help you since you have helped us a lot here, but I dont have the answer for this Q. but hopefully you will find the solution soon. all the best!
     
  4. Daiichi

    Daiichi Club Guest

    Joined:
    Dec 19, 2007
    Messages:
    135
    Likes Received:
    0
    Jarance,

    Hope you be able to find the root cause as this is too technical for most of us here. Remember to share with all when you solve the issue.
     
  5. anaksarawak

    anaksarawak Official Member

    Joined:
    Jan 20, 2007
    Messages:
    4,154
    Likes Received:
    80
    Jarance am sorry I have no knowledge on this issue, maybe we visit ah keong at segambut later
     
  6. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    Thanks guys for the reply. haha even I am stumped..
    I think I might have a solution but I am not sure whether it will work or not.

    Have check the Intake Crankshaft Sensor using Vanos monitoring and found it to working well.

    Did the adaption clearing and also did the throttle adaption. Hopefully this might work.
    Will drive the car in the next few days and see whether it will work. fingers cross.
     
  7. tweiboon

    tweiboon Club Guest

    Joined:
    Dec 23, 2006
    Messages:
    1,509
    Likes Received:
    27
    For parking light turn to orange color, is it brake fluid low ?
     
  8. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    No, it not.
     
  9. Alex5522

    Alex5522 Club Guest

    Joined:
    May 28, 2010
    Messages:
    2,324
    Likes Received:
    21
  10. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
  11. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    Day 1 - small update.

    Drive from Klang to Manjung - No alarm.
    A bit too early to conclude cos was going at an average speed above 110 km/hr.. :p
     
  12. Alex5522

    Alex5522 Club Guest

    Joined:
    May 28, 2010
    Messages:
    2,324
    Likes Received:
    21
    Any 2nd- medium update what's the culprit sifu...
     
  13. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    Day 2 - not so good while driving from Manjung to Ipoh. Encounter two alarms while driving at eighty km/hr.
    On the way back no alarm. So problem us still there.

    Need to study how the close position throttle is stored in the dme. Sigh...
     
  14. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    Day 3 -
    Drive from Manjung to Ipoh in the morning (90 Km) - No Alarm
    Drive from Ipoh to Klang in the evening (220 km) - No Alarm
     
  15. huskar3399

    huskar3399 Club Guest

    Joined:
    Feb 5, 2012
    Messages:
    844
    Likes Received:
    12
    i noticed your icv is somehow different from mine. we share the same engine code m54b25 so i guess the icv shall be identical.

    also i understand you changed so many things already. is it part of preventive maintenance or experimenting to solve the EML issue?
     
  16. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    the picture show the old icv with the new icv. it look the same. no sure how different is your icv.

    most of the parts changed are due to broken part and wear and tear. i changed the icv because of the error code. try to clean it to solve the problem but problem still persist. decide to change it after cleaning it did not solve the problem.
     
  17. huskar3399

    huskar3399 Club Guest

    Joined:
    Feb 5, 2012
    Messages:
    844
    Likes Received:
    12
    oic now the icv photo makes sense to me. yes we share the identical icv.
     
  18. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    Day 4 and 5.

    Driving short distance around Klang area and PJ. No alarm..
     
  19. eujinee

    eujinee Club Guest

    Joined:
    Sep 20, 2010
    Messages:
    301
    Likes Received:
    1
    Seems like some electrical or electronic interference.....since it is intermittent...mayb u can start check ur alternator isit giving the right amount of V during
    idle or rev...should be hovering between 13 - 13.8V..if anything below 12.4V..seems alot crazy things could happen....

    or grouding or mayb fuses.....just give it a try...
     
  20. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,742
    Likes Received:
    233
    Voltage check via INPA is good at 13.1VDC at idling speed.

    Ground all tighten and check in good condition.

    Fuse not check. will give a go when got time. thanks for the suggestion.
     

Share This Page