1. Click here to become an Official Member of BMW Club Malaysia Download Form

Increase Battery discharged E60

Discussion in 'E60, E61' started by Eiffel, Sep 12, 2018.

  1. Eiffel

    Eiffel Member

    Joined:
    Apr 26, 2015
    Messages:
    53
    Likes Received:
    20
    My E60 occasionally occur increased battery discharged msg.

    My battery is 2 years old. After mechanic check, the battery and alternator is charging good. What should I do... is the IBS cable got problem?
     
    dzuljazz2001 likes this.
  2. dzuljazz2001

    dzuljazz2001 Official Member

    Joined:
    Sep 16, 2009
    Messages:
    4,270
    Likes Received:
    51
    Electrical leak cud be frm anything and if you hv a PnP unit in the car, hv it check..
    If not, try checking the.cables to and frm the battery .m
     
  3. Eiffel

    Eiffel Member

    Joined:
    Apr 26, 2015
    Messages:
    53
    Likes Received:
    20
    Hi President,

    May i know what u mean by PNP unit? Because after replacing the battery, my new battery left 60% after a month.

    Thanks.
     
  4. gendong

    gendong Moderator
    Club Committee

    Joined:
    Feb 7, 2011
    Messages:
    3,490
    Likes Received:
    411
    I think he meant did u installed aftermarket equipments like an amp, new speakers, monitor etc...... sometimes its also caused by a usb/charging cable that u plug into the ciggy lighter.
     
  5. Eiffel

    Eiffel Member

    Joined:
    Apr 26, 2015
    Messages:
    53
    Likes Received:
    20
    nope, but my cd changer keep in and out...
     
  6. sixpotters

    sixpotters Official member

    Joined:
    Jan 5, 2005
    Messages:
    78
    Likes Received:
    3
    Hi Eiffel,
    Did you reset the battery computer when you change your battery. Could be the reason why its charging to only 60%
     
  7. Eiffel

    Eiffel Member

    Joined:
    Apr 26, 2015
    Messages:
    53
    Likes Received:
    20
    It is because electrical leakage....they have fixed it.

    My car battery is 846 CCA, is it normal?
     
  8. bimmerdude

    bimmerdude Club Guest

    Joined:
    May 12, 2008
    Messages:
    772
    Likes Received:
    2
    Hey Eiffel, I know this is a very old post, but I'm having the same issue of electrical leakage which just happened for no apparent reason. Mech replaced the engine ECU but problem happened again.
    what was the cause of your electrical leakage and how was it fixed?

    cheers and be Safe!
     
  9. Eiffel

    Eiffel Member

    Joined:
    Apr 26, 2015
    Messages:
    53
    Likes Received:
    20
    hi bro, mine fix once replace my thermostat and coolant pump. (Bluegreen fix it eventually)
     
  10. 321aisyalam

    321aisyalam Club Guest

    Joined:
    Aug 7, 2012
    Messages:
    39
    Likes Received:
    19
    Morning all,
    I had this issue too. Especially car is not being driven once 1 week during this MCO or CMCO period. Then i managed to found the culprit. It was due to my bluetooth dongle which connected to my phone for spotify streaming. The dongle should be off by itself if there is no bluetooth connection or activity. But it just consume the energy from line-in input . Anyway after i unplug it out. It is fine. Weird do. Luckily it is ok now.
     
  11. enkil

    enkil Official Member

    Joined:
    Jul 5, 2009
    Messages:
    1,442
    Likes Received:
    18
    Good to know this. Cheers
     

Share This Page