Group buy: MID & instrument cluster ribbon / ring / bulb

Discussion in 'Group Buys' started by bmw7833, Jan 8, 2012.

  1. theblackbeast

    theblackbeast Club Guest

    Joined:
    Jan 16, 2010
    Messages:
    193
    Likes Received:
    1
    Just now (or 12/04/2012 about 9pm) I managed to fix my cluster with the chrome rings. Sorry still cant post photos from flickr don't know why?
    But I must thank Haywire who guided the group DIY session. I did my own after observing his live guide. MANY THANKS BRO! you rock the DIY world. My next item is the MID.
     
  2. haywire

    haywire Committee Member
    Staff Member Club Committee

    Joined:
    Mar 15, 2009
    Messages:
    4,182
    Likes Received:
    117
    Did you fix the cluster pixel too bro?
     
  3. bmw7833

    bmw7833 Official Member

    Joined:
    Oct 14, 2006
    Messages:
    9,155
    Likes Received:
    46
    Theblackbeast, copy the share code in flickr and paste over here.
     
  4. seech

    seech Club Vendor

    Joined:
    Dec 21, 2006
    Messages:
    982
    Likes Received:
    122
    Can fit E38?
     
  5. bmw7833

    bmw7833 Official Member

    Joined:
    Oct 14, 2006
    Messages:
    9,155
    Likes Received:
    46
    Bro, the ribbon is general use across the model for e38, e39 and e53.
     
  6. seech

    seech Club Vendor

    Joined:
    Dec 21, 2006
    Messages:
    982
    Likes Received:
    122
    Ok. Good to know. If still available, I'll take it. Will PM bro Haywire for details.

    Thanks.
     
  7. haywire

    haywire Committee Member
    Staff Member Club Committee

    Joined:
    Mar 15, 2009
    Messages:
    4,182
    Likes Received:
    117
    This is Seewai's MID unit after I fixed it:

    [​IMG]

    100% pixel in 1 try. There was only 3 vertical lines left before I fixed it. Now fully confident to fix it for you guys.
     
  8. theblackbeast

    theblackbeast Club Guest

    Joined:
    Jan 16, 2010
    Messages:
    193
    Likes Received:
    1
    I did try bro but it does not work...if you dont mind to pm me what you copy from my flickr link to paste in the forum. i did it on the test forum and it works fine, but when i do the same here it does not work??? so confused child I am :)

    oh yes bro...how come i missed that point...yes the pixel came out well..with lots of bling bling.
     
  9. haywire

    haywire Committee Member
    Staff Member Club Committee

    Joined:
    Mar 15, 2009
    Messages:
    4,182
    Likes Received:
    117
    What do you mean by bling bling?
     
  10. Gerald 5

    Gerald 5 Club Guest

    Joined:
    Jan 29, 2008
    Messages:
    691
    Likes Received:
    1
    Hi Bro Haywire,

    This is how my MID looks like at current, the S(T) indicating stereo sometime gone half missing. Since I bought the ribbon, might a swell fix it. See you at 6pm today?
    [​IMG]
     
  11. haywire

    haywire Committee Member
    Staff Member Club Committee

    Joined:
    Mar 15, 2009
    Messages:
    4,182
    Likes Received:
    117
    Sure can. See you today.
     
  12. theblackbeast

    theblackbeast Club Guest

    Joined:
    Jan 16, 2010
    Messages:
    193
    Likes Received:
    1
    means very nice ......he..he....
     
  13. bmw7833

    bmw7833 Official Member

    Joined:
    Oct 14, 2006
    Messages:
    9,155
    Likes Received:
    46
    Click share and select the BB code.
     
  14. seewai

    seewai S62B50

    Joined:
    Feb 29, 2008
    Messages:
    2,118
    Likes Received:
    35
    Could have cucuk into my car and get the original only-3-vertical-lines-left picture for comparison :banghead: ...but then we were all orgasmic on that cluster that time weren't we?
     
  15. haywire

    haywire Committee Member
    Staff Member Club Committee

    Joined:
    Mar 15, 2009
    Messages:
    4,182
    Likes Received:
    117
    I did test it on Fariz's car the day before. Thats how I know there's 3 lines left. No photos though.
     
  16. seewai

    seewai S62B50

    Joined:
    Feb 29, 2008
    Messages:
    2,118
    Likes Received:
    35
    Ic, I had the 3 lines, delivered together with my ride when I brought her back on Feb 2008.
     
  17. seewai

    seewai S62B50

    Joined:
    Feb 29, 2008
    Messages:
    2,118
    Likes Received:
    35
    So it's close to a month now since the ribbon cable repair was done. When I reached home today, I notice about half a line went missing.
     
  18. bmw7833

    bmw7833 Official Member

    Joined:
    Oct 14, 2006
    Messages:
    9,155
    Likes Received:
    46
    Cluster or MID?
     
  19. seewai

    seewai S62B50

    Joined:
    Feb 29, 2008
    Messages:
    2,118
    Likes Received:
    35
    It's the MID that has some missing pixels.

    I didn't get the cluster one done.
     
  20. haywire

    haywire Committee Member
    Staff Member Club Committee

    Joined:
    Mar 15, 2009
    Messages:
    4,182
    Likes Received:
    117
    I'll see you again, its the pressure bar not putting enough pressure. Yours was the first MID I fixed so I know more now.
     

Share This Page