1. Click here to become an Official Member of BMW Club Malaysia Download Form

EasyDIS 44 and INPA working

Discussion in 'General Tech' started by aidilj, Mar 10, 2011.

  1. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,743
    Likes Received:
    233
    $120 - USD or RM?

    I got my cable for USD61 (cable) + USD22 (freight). The price include DVD Rom as well.

    Follow aidil advise. You should test out the cable first and ensure that it work.
     
  2. aidilj

    aidilj Official Member

    Joined:
    Jul 3, 2010
    Messages:
    2,291
    Likes Received:
    22
    Didn't reset the adaptation value after reading some posts online saying only do it when advised or after changing parts to new one. I'm also afraid doing anything fancy.

    So instead spent the morning changing the solenoid valve O-rings. While hands were dirty, airbag warning goes up again, and the sporadic error was cleared.

    Then did DME error message read in INPA, errors as follows



    E R R O R M E M O R Y
    ---------------------------------------
    Date: 24.04.2011 11:57:55
    ECU: ME9K42
    JobStatus: OKAY
    Variant: ME9K42
    -------------------------------------------------------------
    RESULT: 3 error in error memory !
    -------------------------------------------------------------
    271D CDKHSV - Oxygen sensor heater before cat.
    Error counter: 1
    Logistic counter: 40
    Mileage 120430 km
    Voltage LS-heater before cat (uhsv) 2.05 V
    Time after start (tnse_u) 51.20 s
    Supply voltage (ub) 13.66 V
    Vehicle speed (vfzg_u) 12.00 km/h
    mangelnde Signalbereitschaft
    Test conditions fulfilled
    Error present now and already stored
    Error would cause a warning lamp to light up
    Error code: 03 27 1D E8 11 01 28 2F 0B 69 02 91 0C FF FF FF
    FF FF FF FF FF FF FF FF
    -------------------------------------------------------------
    2722 CDKLSV2 - Oxygen sensor2 before cat.
    Error counter: 5
    Logistic counter: 40
    1. Umweltsatz
    Mileage 121470 km
    StatusByte LSU not plausible B2 (lsunpstat2) 4.00 bin
    LSU-voltage bef.cat bank2 (ADC) (uulsuv2_u) 4.88 V
    Exhaust temp. bef.cat out of model bank2(tabgm2) 165.00 Grd C
    Sensor voltage before cat bank2 (ushk2) 0.45 V
    2. Umweltsatz
    Mileage 121480 km
    StatusByte LSU not plausible B2 (lsunpstat2) 4.00 bin
    LSU-voltage bef.cat bank2 (ADC) (uulsuv2_u) 4.88 V
    Exhaust temp. bef.cat out of model bank2(tabgm2) 200.00 Grd C
    Sensor voltage before cat bank2 (ushk2) 0.45 V
    3. Umweltsatz
    Mileage 122040 km
    StatusByte LSU not plausible B2 (lsunpstat2) 5.00 bin
    LSU-voltage bef.cat bank2 (ADC) (uulsuv2_u) 0.21 V
    Exhaust temp. bef.cat out of model bank2(tabgm2) 875.00 Grd C
    Sensor voltage before cat bank2 (ushk2) 0.61 V
    Signal unplausibel
    Test conditions fulfilled
    Error present now and already stored
    Error would cause a warning lamp to light up
    Error code: 03 27 22 E8 11 05 28 2F 73 04 FA 2B 7D 2F 74 04
    FA 32 7D 2F AC 05 0B B9
    -------------------------------------------------------------
    2727 CDKLASH2 - Lambda sensor ageing after cat bank2
    Error counter: 1
    Logistic counter: 30
    Mileage 121490 km
    Engine speed (nmot) 1680.00 /min
    Cat temp. out of the model bank2(tkatm2) 375.00 Grd C
    Inside resistor LS before cat bank2 (rinh2) 192.00 Ohm
    Sensor voltage before cat bank2 (ushk2) 0.67 V
    Sondenspannung unterschreitet Schwellwert nicht
    Test conditions fulfilled
    Error not occurred yet
    Error would not cause a warning lamp to light up
    Error code: 03 27 27 02 01 01 1E 2F 75 2A 55 03 A7 FF FF FF
    FF FF FF FF FF FF FF FF
    =============================================================
     
  3. IanDaddy

    IanDaddy Club Guest

    Joined:
    Sep 29, 2009
    Messages:
    528
    Likes Received:
    5
    I did steering angle adjustment/calibration on an 05 E90 320i to delete the steering angle sensor fault code with DIS. Success, it was quite straight forward.
     
  4. IanDaddy

    IanDaddy Club Guest

    Joined:
    Sep 29, 2009
    Messages:
    528
    Likes Received:
    5
    Jarance,

    I am looking to buy a similar cable like yours. Can you PM me the site you purchased it from ?

    My al-cheapo cable cannot access some modules (I think it is the CAS) in an 06 E90 though it can detect most including the chassis.

    Thanks
     
  5. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,743
    Likes Received:
    233
    Let meet this friday at paparich. I show what I have and what it can do. No point buying the cable and find that
    it does not work later.

    I have not test it on an E90 yet so I am dying to know what my scanner can do. So bring an e90.
     
  6. IanDaddy

    IanDaddy Club Guest

    Joined:
    Sep 29, 2009
    Messages:
    528
    Likes Received:
    5
    Aiya, E90 belongs to friend. So far I have adjusted steering angle , reset adaptation , diagnose for a 05 E90. Managed to detect and run short test on another 06 E90, just cannot properly do the condition based service reset.
    Would there be another forumer/member at the TT with a E90/E60 later than 05 ?
    I will try to make it to the TT , the place at PJ.
     
  7. xcrave

    xcrave Club Guest

    Joined:
    Nov 16, 2010
    Messages:
    720
    Likes Received:
    0
    I think it will work on E90... do read the cable limitation tho... Jarance cable spec (if its the same as im ordering (dame snail processing by custom)

    Models that require D-CAN:
    - E60, E61 after 3/2007
    - E83 after 9/2006
    - E81, E87 after 3/2007
    - E90, E91, E92, E93 after 3/2007
    - E70 (New X5)
    - R56 (New Mini)
     
  8. xcrave

    xcrave Club Guest

    Joined:
    Nov 16, 2010
    Messages:
    720
    Likes Received:
    0
    Got my OBD II cable 2 weeks back, Installed GT1 but yet to use it... going down to my car as we speak...

    [​IMG]

    Package came with a newer version of GT1 and SSS program installing it also as i post this... will have tons of question coming soon :p
     
  9. IanDaddy

    IanDaddy Club Guest

    Joined:
    Sep 29, 2009
    Messages:
    528
    Likes Received:
    5
    good on you xcrave, wish you success.
    it is such a PITA to download SSS, perhaps can borrow your CD when you are done ?
     
  10. xcrave

    xcrave Club Guest

    Joined:
    Nov 16, 2010
    Messages:
    720
    Likes Received:
    0
    :p Wakakaka well tell you a secret... for this link :

    http://www.4shared.com/dir/LfFoCBq2/An_EasyDis_Machine.html

    pass: bimmerforums

    All you need is a great software called miponi

    http://www.mipony.net/downloads/Mipony-Installer.exe

    All you need to do next is past the link to mipony and it will wait for you and arrange all ur trouble! :)

    Good luck !

    I downloaded all of the files in just one night...

    BTW

    Question to everyone... ive followed all the instruction given in INPA/DIS...

    So far i can only get INPA working

    But inpa wont let me scan other than Engine Live data and everything under Engine...

    Im using the 16 pin (just found out there is one OBD II port under my steering ) hu hu hu...

    Im going to mod the china 20 pin cable from jarance and see if i can get better result from the 20 pn on the front...

    INPA problem is that "no connection to diag head"

    Any idea?
     
  11. aidilj

    aidilj Official Member

    Joined:
    Jul 3, 2010
    Messages:
    2,291
    Likes Received:
    22
    So youre able to view live data in modules under engine. When do you get the "no connection to diag head" message? Check your OBD interface and make sure that pin 7 and 8 of the OBDII pins are shorted, this may cause you to only read from some module.

    Trying the 20pin OBD port under the hood is a good experiment. My car no longer have OBD port at the engine bay. Why do you need to mod Jarance's 20-16pin converter?
     
  12. IanDaddy

    IanDaddy Club Guest

    Joined:
    Sep 29, 2009
    Messages:
    528
    Likes Received:
    5
    Thanks xcrave, I use the same 4shared site. Will download the Mipony.
     
  13. aidilj

    aidilj Official Member

    Joined:
    Jul 3, 2010
    Messages:
    2,291
    Likes Received:
    22
    Felt like bumping this thread after reading through to do my revision. :burnout:
     
  14. IanDaddy

    IanDaddy Club Guest

    Joined:
    Sep 29, 2009
    Messages:
    528
    Likes Received:
    5
    aidilj, yeah bump it up.
     
  15. erica34

    erica34 Club Guest

    Joined:
    Dec 7, 2004
    Messages:
    845
    Likes Received:
    2
    +1. good thread. reminds me i need to do something about getting the bits i have working. i've got an usb obdII cable similar to the one on post #128 by xcrave and for obdI an ADS interface from miglenium. just haven't got round to installing the software after changing laptop. switched to an old model latitude d630 for its native serial port. also it's got more processing power and memory compared to the x41 i used earlier.
     
  16. bmwtech857

    bmwtech857 Club Guest

    Joined:
    Mar 12, 2012
    Messages:
    4
    Likes Received:
    0
    Does anyone know what the ip settings and adapter settings are for connecting a real yellow diag head to the EasyDis??
     
  17. aidilj

    aidilj Official Member

    Joined:
    Jul 3, 2010
    Messages:
    2,291
    Likes Received:
    22
    Hi bmwtech857, welcome to the board. As far as I know and remember last time. You'll need to use a software called diaghead emulator to use the yellowhead with easydis.
     
  18. jarance

    jarance Founding Member

    Joined:
    Dec 4, 2004
    Messages:
    14,743
    Likes Received:
    233
    Aidil.

    Can INPA be used for F10?
     
  19. aidilj

    aidilj Official Member

    Joined:
    Jul 3, 2010
    Messages:
    2,291
    Likes Received:
    22
    Jarance,

    Don't know for sure, but last time I have an INPA version that goes as late as f01

    [​IMG]
     
  20. bmwtech857

    bmwtech857 Club Guest

    Joined:
    Mar 12, 2012
    Messages:
    4
    Likes Received:
    0

    Thank you for the reply. I have a actual head from bmw made by siemens. If i bridge the vmware adapter with the real adapter the head shows up but i can't connect. It said the head was outside the network. with the normal setting the head will not show up at all. i was sure there was a way to connect them by setting the proper ip in windows and matching it with the gt 1 settings.
     

Share This Page