1. Click here to become an Official Member of BMW Club Malaysia Download Form

EasyDIS 44 and INPA working

Discussion in 'General Tech' started by aidilj, Mar 10, 2011.

  1. erica34

    erica34 Club Guest

    Joined:
    Dec 7, 2004
    Messages:
    845
    Likes Received:
    2
    you could try the ADS interface from Mig. See link below.

    http://www.miglenium.de/workshop_obd-ads.html

    i bought one after getting vm of DIS57/SSS32 onto my laptop. obviously didn't work... knew jack about diagnostic stuff when i got it. only realised later vm setup also requires dk yellow head. case of do first, read/research later... ahkaka.
     
  2. IanDaddy

    IanDaddy Club Guest

    Joined:
    Sep 29, 2009
    Messages:
    528
    Likes Received:
    5
    Used INPA to reset lambda and Throttle adaptation, did not feel much of a difference.
    Run the Vanos Test but program ran into errors (some API related errors, could be the cable, I was using a 30 feet extension RS232 cable) . Will try again
     
  3. aidilj

    aidilj Official Member

    Joined:
    Jul 3, 2010
    Messages:
    2,291
    Likes Received:
    22
    30 feet is loong, couldve cause the signal deterioration.

    I am also wondering whered you get your INPA/EDIABAS cable, you sound like a happy customer.
     
  4. IanDaddy

    IanDaddy Club Guest

    Joined:
    Sep 29, 2009
    Messages:
    528
    Likes Received:
    5
    aidilj, i was just experimenting. I was able to reset some adaptation to the extension but Vanos Leak Test did not complete , the errors look like is related to the communication (signal deterioration like you said). I will try again with shorter cable and also serial-usb adapter. I will try with different COM port settings, i understand that FIFO must be enabled and the I/O buffer must be set to 8.

    I got mine from a Chinese online store, bought other items as well. It would have been great to home-make but too lazy, don't know where I have chucked those soldering tools.
     
  5. M3addict

    M3addict Club Guest

    Joined:
    Mar 10, 2011
    Messages:
    132
    Likes Received:
    2
    done d/loading EasyDIS, VMware, Carsooft 6.5,
    EDIABAS 6.4.3 and INPA 4.47 coz mine wasn't 64-bit OS.
    currently using winxp sp3 and other pc were win7 32-bit.
    so did i d/load the right EDIABAS?

    coz read ur 1st post mention u r using win7 64-bit...
    thx a lot for ur guide...
     
  6. aidilj

    aidilj Official Member

    Joined:
    Jul 3, 2010
    Messages:
    2,291
    Likes Received:
    22
    Hi M3 it seems like you're almost in a different timezone..!

    Anyhoo, I think it is okay to get the later version of INPA/EDIABAS for your machine. It will still work on your XP just that it has drivers that supports x64 too. Give it a try.
     
  7. IanDaddy

    IanDaddy Club Guest

    Joined:
    Sep 29, 2009
    Messages:
    528
    Likes Received:
    5
    I tried the INPA 5.02 yesterday. Could not get it to work yet. M3, you will need the GT1 V44 as well.
     
  8. aidilj

    aidilj Official Member

    Joined:
    Jul 3, 2010
    Messages:
    2,291
    Likes Received:
    22
    IanDaddy, INPA 5.02 can't work on 32bit windows?
     
  9. IanDaddy

    IanDaddy Club Guest

    Joined:
    Sep 29, 2009
    Messages:
    528
    Likes Received:
    5
    I have a problem with the installation. I tried the upgrade path but could not select either during installation. Fresh install after old version uninstalled also could not select INPA and Ediabas during install, I think there are still some other files which I need to remove.

    Also, there is a setup.exe in 'program installation' folder and there is one instprog.exe in 'Referenz/install' folder . Tried both.

    The .iso image I have is 333,304 KB.
     
  10. aidilj

    aidilj Official Member

    Joined:
    Jul 3, 2010
    Messages:
    2,291
    Likes Received:
    22
    Okay, is this downloaded from the same location in first post of the thread? It comes with install instructions, delete c:\INPA and c:\EDIABAS and if you have it c:\ECC-APP
     
  11. IanDaddy

    IanDaddy Club Guest

    Joined:
    Sep 29, 2009
    Messages:
    528
    Likes Received:
    5
    Yes, followed the instructions. I have delete all those folders too, i will check if there is any registry entries.
     
  12. M3addict

    M3addict Club Guest

    Joined:
    Mar 10, 2011
    Messages:
    132
    Likes Received:
    2
    i only use old pc la bro that's y only support winxp :)

    [​IMG]

    still trying to install GT1....a bit hard coz never use that daemon tools....
     
  13. skinhead

    skinhead Club Guest

    Joined:
    Dec 6, 2004
    Messages:
    451
    Likes Received:
    1
    aidil,

    ive managed to installed easydis and inpa on my winxp ntebook last nite. im using carsof cable + usb serial convertor. but its giving me error 200.159
    i guess the carsof cable is not usable wit easydis.
    some pic View attachment 18720
     
  14. IanDaddy

    IanDaddy Club Guest

    Joined:
    Sep 29, 2009
    Messages:
    528
    Likes Received:
    5
    Skinhead,

    Perhaps you can try this. Start up your PC, connect the carsoft cable, start carsoft first then close it. Now start DIS.
     
  15. skinhead

    skinhead Club Guest

    Joined:
    Dec 6, 2004
    Messages:
    451
    Likes Received:
    1
    yup yup,

    i just realised i made some setup mistake jus now. i need to config the ip add for the virtual netwrk. will do tht and update...
     
  16. aidilj

    aidilj Official Member

    Joined:
    Jul 3, 2010
    Messages:
    2,291
    Likes Received:
    22
  17. skinhead

    skinhead Club Guest

    Joined:
    Dec 6, 2004
    Messages:
    451
    Likes Received:
    1
    managed to setup the ip properly. IFHS is connected to 192.168.68.30. run the diagnose, now giving me terminal 15 voltage error...:stupid: after 2days of trying im :banghead:

    aidil, do u mind passing me the BOM&schematic for the inpa/ediabas interface cable. ?
     
  18. aidilj

    aidilj Official Member

    Joined:
    Jul 3, 2010
    Messages:
    2,291
    Likes Received:
    22
    skinhead, if your interface works with INPA then it should work with EasyDIS too. In INPA, do both indicators, battery and ignition turned on? They both should turn on when the connector is connected to the OBD port. Try the interface with INPA first then EasyDIS.

    Schematic for INPA/EDIABAS is as posted in the first page. I'm posting it here again.. Other than the components in the schematic you would need

    OBDII connector
    RS232 DB-9 female connector
    A multicore cable
    Veroboard/stripboard

    Cheers

    [​IMG]
     
  19. skinhead

    skinhead Club Guest

    Joined:
    Dec 6, 2004
    Messages:
    451
    Likes Received:
    1
    hi aidil,

    only selected module works with INPA. in INPA, both indicators, battery and ignition turned off
    i think my carsof cable f0ckup. even in carsof now it will intermittently lost connection. either i follow ur footstep in building the odb interface or i buy the chinese one.
    how cheap is odbii connector and mc33290 ic??
    tq
     
  20. aidilj

    aidilj Official Member

    Joined:
    Jul 3, 2010
    Messages:
    2,291
    Likes Received:
    22
    skinhead, the components to build the connector is cheap but other charges made it expensive, more expensive than ready made one even. Here's the breakdown

    2 x OBD-2 Connector right angle = 9.66 EUR
    1 x MC33290 = 1.55 EUR

    subtotal = 11.21 EUR
    shipping = 15.50 EUR
    paypal charge = 3.36 EUR

    total = 30.07 EUR

    today, this would convert to RM129 while you can get one off eBay with RM100 with round connector converter and no soldering. Okay you can knock 5 EUR/RM 21 because I bought two connectors, but still..

    I posted a link to an eBay seller in an earlier post
     

Share This Page